Advanced Search is unavailable

Incident Report for Rhaegal

Resolved

This incident has been resolved.
Posted Jun 01, 2023 - 12:04 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 01, 2023 - 11:43 CEST

Investigating

Currently, candidates are unable to open the Advanced Search on career pages. We are working on deploying a fix.
Posted Jun 01, 2023 - 11:16 CEST