Some jobs might be not displayed on maps
Incident Report for Rhaegal
Resolved
This incident has been resolved.
Posted Dec 21, 2022 - 15:38 CET
Identified
The Sync between SmartRecruiters and Beekome is partially down. Some jobs might be unavailable on maps. We are fixing the issue.
Posted Dec 21, 2022 - 11:13 CET