Applicants are not moved to the new status after submitting the form
Incident Report for Rhaegal
Resolved
This incident has been resolved.
Posted Sep 09, 2022 - 17:21 CEST
Investigating
We are currently investigating this issue.
Posted Sep 09, 2022 - 16:40 CEST
This incident affected: Form4Smart.