Unable to send attachments in forms
Incident Report for Rhaegal
Resolved
This incident has been resolved.
Posted Mar 09, 2023 - 11:46 CET
Investigating
We are currently investigating this issue.
Posted Mar 08, 2023 - 16:28 CET
This incident affected: Form4Smart.