Unable to load career pages
Incident Report for Rhaegal
Resolved
This incident has been resolved.
Posted Jul 25, 2022 - 10:08 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 25, 2022 - 09:48 CEST
This incident affected: Beekome.